Author Topic: *.poison is always zero RESOLVED 2.43.1k  (Read 1567 times)

Offline Moonfisher

  • Bot Overlord
  • ****
  • Posts: 592
    • View Profile
*.poison is always zero RESOLVED 2.43.1k
« on: April 19, 2008, 11:00:48 AM »
Just noticed all my bots produce poison non stop... and it seems like it may also be whats causing Excalibur to fall appart... not sure if *.shell is actualy broken aswell... but it seems like *.poison is...
Don't have a case or anything, poison just return 0 in the console even if you have some... if you wan't a sim or bot to test it I'll find something...
« Last Edit: April 28, 2008, 02:08:24 PM by EricL »

Offline EricL

  • Administrator
  • Bot God
  • *****
  • Posts: 2266
    • View Profile
*.poison is always zero RESOLVED 2.43.1k
« Reply #1 on: April 21, 2008, 11:42:00 AM »
poison appears to be being made correctly and reflected in bot memory correctly according to my tests.

I'll need a sim or some bot DNA to proceed.
Many beers....

Offline Moonfisher

  • Bot Overlord
  • ****
  • Posts: 592
    • View Profile
*.poison is always zero RESOLVED 2.43.1k
« Reply #2 on: April 21, 2008, 03:22:46 PM »
Oook, it's a litle odd this bug.
It seems like it depends on the eyes somehow... if they're empty it keeps producing poison and venom.
The console also seemed to work this time, even when the bot wasn't working.
The bots with something in their seight seem to work as intended.
Did a very simple test, included bot and sim and a screenshot.

Offline EricL

  • Administrator
  • Bot God
  • *****
  • Posts: 2266
    • View Profile
*.poison is always zero RESOLVED 2.43.1k
« Reply #3 on: April 21, 2008, 04:26:39 PM »
The code that zeros out the refvars was mistakenly zeroing out the memory locations that reflect the amount of venom and poison a bot has.  Thus when a bot has nothing in it's focus eye, .poison and .venom would be 0.

Thanks for the sim and DNA.

Fixed in 2.43.1j.
Many beers....

Offline Moonfisher

  • Bot Overlord
  • ****
  • Posts: 592
    • View Profile
*.poison is always zero RESOLVED 2.43.1k
« Reply #4 on: April 26, 2008, 03:00:55 PM »
Ran DB 2.43.1j... and I don't think you fixed the bug... it also looks like I can no longer avoid the bug by checking the eyes, or maybe it's just the eyes on spinner...
Either way it keeps making venom just like last time, and I think the poison bug is still there aswell...

It also seems like a lot of bots the league bots die after a few cycles in the new drop... dunno what's happening, just noticed bots like Martian Tank 2 dieing realy fast, and a lot of other bots also seem to die mysteriously after some time...
« Last Edit: April 26, 2008, 03:06:56 PM by Moonfisher »

Offline EricL

  • Administrator
  • Bot God
  • *****
  • Posts: 2266
    • View Profile
*.poison is always zero RESOLVED 2.43.1k
« Reply #5 on: April 28, 2008, 02:10:16 PM »
Okay, really fixed it this time in 2.43.1k


If you get more info on the league issues, please open a separate bug.  Thanks.
Many beers....