Author Topic: Crash to desktop  (Read 3488 times)

Offline Peksa

  • Bot Destroyer
  • ***
  • Posts: 118
    • View Profile
Crash to desktop
« on: April 25, 2008, 01:43:09 PM »
This is a bit mysterious. Whenever I'm running a sim with .sexrepro I get random CTDs. They don't produce error.sim to post, but instead a windows error report pops up. The pictures I've attached are screencaptures from the error report. They have the same dll file on them, ntdll.dll. I've also attached a sim that reproduces these errors quite often (the zip-file). I'm using almost exactly same settings in my other sim with no problems. The only main difference is the species that uses .sexrepro instead of .repro.

Also, I've got dual core, so I'm running two different sims at once, if that matters. The other one runs fine though (no sexrepro there).

Offline Peksa

  • Bot Destroyer
  • ***
  • Posts: 118
    • View Profile
Crash to desktop
« Reply #1 on: April 28, 2008, 10:03:01 AM »
This error is killing my .sexrepro sim. I can't run one for more than couple of hours without it. Could it be system spesific? Ie. could replacing ntdll.dll fix the problem? I don't like to fiddle with .dll files needlessly.

Offline EricL

  • Administrator
  • Bot God
  • *****
  • Posts: 2266
    • View Profile
Crash to desktop
« Reply #2 on: April 28, 2008, 10:26:57 AM »
Quote from: Peksa
This error is killing my .sexrepro sim. I can't run one for more than couple of hours without it. Could it be system spesific? Ie. could replacing ntdll.dll fix the problem? I don't like to fiddle with .dll files needlessly.
I'll look at it today...
Many beers....

Offline EricL

  • Administrator
  • Bot God
  • *****
  • Posts: 2266
    • View Profile
Crash to desktop
« Reply #3 on: May 07, 2008, 11:21:19 AM »
I got this to crash once, but the symbols didn't load right.  I'll run it over night in the IDE tonight.
Many beers....