Author Topic: Breaking news: Internet Mode horrible, non-functional  (Read 10618 times)

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #45 on: February 21, 2014, 10:47:06 AM »
Quote
What should I do with pid?

Nada, the only two you need are the in/out



Fix for file ignore in 30 minutes, let me finish eating.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #46 on: February 21, 2014, 11:21:09 AM »
Peter, I have tested this, should work:

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #47 on: February 21, 2014, 02:21:21 PM »
Quote
A different extension would probably work.

It does now. Also, there is a new bug fix for Testlund that will most likely apply to IM as well. Check out Bugs and fixes forum...
Also, I would like to have some kind testing schedule to test IM. I can help diagnose errors that are vb6 related.
« Last Edit: February 21, 2014, 04:47:09 PM by Botsareus »

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #48 on: February 21, 2014, 04:57:02 PM »
Peter, you can use the third parameter if you like to prevent transferring robots back to yourself. However, that will make it uncompatible with the parameterless version. Therefor the use of teleporters will become completely unpractical. The way vb6 sends the parameters is it shells DarwinBotsIM.exe with them, you may consider moving and renaming your 'client.exe' to 'DarwinBotsIM.exe'

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #49 on: February 21, 2014, 07:08:26 PM »
Minor detail, can you put quotes around the name, to get 'Newbie' and '5676' in the same argument.

''-in "C:\in" -out "C:\out" -name Newbie 5676 -pid  4404

to

''-in "C:\in" -out "C:\out" -name "Newbie 5676" -pid  4404
« Last Edit: February 21, 2014, 07:10:16 PM by Peter »
Oh my god, who the hell cares.

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #50 on: February 22, 2014, 07:25:39 PM »
Server is up, new client added. Which can work in the old spot and as a replacement of DarwinBotsIM, in which case it used the DB internet name as a identifier for the server.

As for testing schedule, I'll put this online till I find some serious issues with how it works.
Oh my god, who the hell cares.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #51 on: February 23, 2014, 12:22:39 PM »
So it is up then? I'll start playing with it by Tuesday.
Peter, your name is going on the credits, thx for help.

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #52 on: February 23, 2014, 04:26:10 PM »
It's still not as stable as it should. ;)

Rather easy to break the server if you know how it works~

Should quickly send around bots now, though.
Oh my god, who the hell cares.

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #53 on: February 24, 2014, 12:42:39 PM »
If anyone tried to connect. The reason it failed was because the firewall blocked you. Port forwarding should now work properly...
Oh my god, who the hell cares.

Offline MysticalDumpling

  • Bot Destroyer
  • ***
  • Posts: 205
  • Kurwa chuj!
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #54 on: February 24, 2014, 05:06:42 PM »
I am on right now- the widow that opens up (MSDOS?) flashes with text and closes. Is this what is supposed to happen, or
To być albo nie być, oto jest ze pytanie

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #55 on: February 24, 2014, 05:17:40 PM »
If you run it from within Darwinbots, it may happen if you got a space in your username.

Simulation settings-> internet-> User name, pick a user name without spaces and it shouldn't crash.
Oh my god, who the hell cares.

Offline MysticalDumpling

  • Bot Destroyer
  • ***
  • Posts: 205
  • Kurwa chuj!
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #56 on: February 24, 2014, 05:34:05 PM »
OK. Now it stays open... Ill try to seem if anything comes in!
To być albo nie być, oto jest ze pytanie

Offline MysticalDumpling

  • Bot Destroyer
  • ***
  • Posts: 205
  • Kurwa chuj!
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #57 on: February 24, 2014, 06:26:47 PM »
Peter- I got some of your bots!
To być albo nie być, oto jest ze pytanie

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #58 on: February 25, 2014, 02:30:12 PM »
It is working!

Btw, library is a required file :/ I wish we can partially include this zip, it is a big one.

For a while I was not getting anything, sending anything and it was saying "no robots on server" is that normal?

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Re: Breaking news: Internet Mode horrible, non-functional
« Reply #59 on: February 25, 2014, 02:42:20 PM »
The most likely reason for not sending anything is that a client shut down a connection in the middle of a transaction. Server waits on a non existing client till it times out the server socket and it restarts.

No robots on server is quite common. It tries to put 25 bots in the inbound folder, as DB can more quickly import bots than export them it quickly loses any cache it got if there's more than one user.
Oh my god, who the hell cares.