Author Topic: Weird teleporter problem.  (Read 3350 times)

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Weird teleporter problem.
« Reply #30 on: February 11, 2014, 11:38:40 AM »
edit: Let me refraze this:

As soon us the advanced mutations are enabled the teleporters completely stop working?

another edit:

Do I have to use a specific robot?

I want to get to this some time Wednesday.



Quote
I think you fixed with version Darwin2.46.02BetaH that involved file names/access.

 :Party6:  :)
« Last Edit: February 11, 2014, 03:28:02 PM by Botsareus »

Offline Testlund

  • Bot God
  • *****
  • Posts: 1574
    • View Profile
    • Games And Electronica
Re: Weird teleporter problem.
« Reply #31 on: February 11, 2014, 07:25:16 PM »
No, you go into the Global Settings tab and put checkmarks in all the boxes on the mutations tab, then you have to click start/change and then quit DB for those settings to take affect.

Next time you start DB you start new sims with A and B instances like before, but you will now run with the new mutation features.

I've doing tests where I started off with your template as I call it, then I've added stuff/settings a few at a time to figure out where the teleporter problems begins.

So far I seem to have narrowed it down to be the "Epigenetic Reset" and/or "Normalize default mutation rates..." to be what's messing up the teleporting.

We're getting closer! It's getting hot!  :D
"God is an ever receding pocket of scientific ignorence." - Neil DeGrasse Tyson

"God is a kid with an ant farm" - Constantine

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Weird teleporter problem.
« Reply #32 on: February 12, 2014, 11:40:03 AM »
Sounds like any robot will suffice to me. I will set one up with 'TheOne'

edit: I will also try it with

Code: [Select]
0
0
0
0
0
0
0
0

If I can not get theone to fail. That is the smallest zero bot I have ever seen!
« Last Edit: February 12, 2014, 03:45:45 PM by Botsareus »

Offline Testlund

  • Bot God
  • *****
  • Posts: 1574
    • View Profile
    • Games And Electronica
Re: Weird teleporter problem.
« Reply #33 on: February 12, 2014, 04:38:13 PM »
Yes, the kind of bot shouldn't matter in this case. For my bots and settings I have a weakness for 8 bit increments (actually I favor the number 32 and like to go from there). Just something I like to use which I don't think matters much. I use this for music projects too as a starting point.  :P

I think this teleporter bug is the nastiest I've seen so far in DB. Very hard to track what the exact cause is. I'm just telling you what appears to me to be the most likely cause of the bug; some new data is being put into the bot files that the teleporter program don't understand. So something hits a red teleporter and the teleporter goes like "what the hell is this?"

Right now I'm running two instances with the two (what I think) culprits unchecked and it runs fine.
"God is an ever receding pocket of scientific ignorence." - Neil DeGrasse Tyson

"God is a kid with an ant farm" - Constantine

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Weird teleporter problem.
« Reply #34 on: February 13, 2014, 06:22:42 PM »
I have decided to adapt Numsgils naming convention, any revision will now have the last two digits change instead of "betaA" "betaB" etc.
Any major improvement in functionality will have the second set of digits change such as "2.47" instead of "2.46" The next big one will be called 2.47

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Weird teleporter problem.
« Reply #35 on: February 18, 2014, 10:59:12 AM »
Ok, the overall speed and stability has been improved.

Offline Testlund

  • Bot God
  • *****
  • Posts: 1574
    • View Profile
    • Games And Electronica
Re: Weird teleporter problem.
« Reply #36 on: February 20, 2014, 08:23:49 AM »
The problem is still there. If I have the two features I've mentioned above selected bots can't teleport.

Personally I don't mind. I don't think I will be using them in my own sims, cause I don't even know what they do. I've just been testing them to see if they work.
"God is an ever receding pocket of scientific ignorence." - Neil DeGrasse Tyson

"God is a kid with an ant farm" - Constantine

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Re: Weird teleporter problem.
« Reply #37 on: February 20, 2014, 04:20:43 PM »
I suspect the organism validation looks at something it doesn't recognize. You might throw in a popup if a organism is misformed and look what it does.

Also, it could happen that DB1 loads the file while DB2 saves it and deletes it upon wrong validation. I don't think it'll be as much as 1/3 losses, but can account for some bots. More likely to happen with more cycles/second as directories are at default accessed every 10 cycles.
Oh my god, who the hell cares.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Weird teleporter problem.
« Reply #38 on: February 21, 2014, 04:39:15 PM »
I found a very rear accruing error and fixed it. It indeed had to do with 'normalize default mutation rates' It did not happen all the time because of how DB instantiates a new robot. Anyway, try this drop and let me know if it works now.

Just found another related bug, now with sunbelt mutations disabled a robot that is being transferred from such a simulation to one where the stuff is enabled will have zero for these values. This does mean however that if you load a simulation that is pre 2.46.05 the sunbelt mutations will be automatically disabled for all robots.
« Last Edit: February 21, 2014, 05:53:29 PM by Botsareus »