Author Topic: Subscript out of range when running sim Darwin2.46.02BetaA  (Read 646 times)

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Subscript out of range when running sim Darwin2.46.02BetaA
« on: January 10, 2014, 05:00:31 PM »
Was changing some settings in db, suddenly I couldn't restart the sim. Exit sim and on restart it messes up.

Quote
An Error Occured. Darwinbots cannot continue. Sorry. Subscript out of range
Darwinbots 9 203.
Oh my god, who the hell cares.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Subscript out of range when running sim Darwin2.46.02BetaA
« Reply #1 on: January 11, 2014, 04:59:29 PM »
ok, I'll take a look.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Subscript out of range when running sim Darwin2.46.02BetaA
« Reply #2 on: January 12, 2014, 10:57:08 AM »
It looks like your save file somehow go corrupt. Investigating further.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Subscript out of range when running sim Darwin2.46.02BetaA
« Reply #3 on: January 12, 2014, 11:20:45 AM »
Yea, it looks like it is just a corrupt file.
I am going to recreate an autosave situation, but it does not look promising that I can fix this.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Subscript out of range when running sim Darwin2.46.02BetaA
« Reply #4 on: January 12, 2014, 11:40:37 AM »
ok here is an uncorrupt save file that loaded fine: