Author Topic: Subscript out of range when running fresh install with 2.46.02Beta  (Read 766 times)

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Unconfirmed as yet.
Peter please post here.

Offline Peter

  • Bot God
  • *****
  • Posts: 1177
    • View Profile
Re: Subscript out of range when running fresh install with 2.46.02Beta
« Reply #1 on: January 09, 2014, 05:19:03 PM »
Clean install db2, run 2.46.02Beta.

At startup you get the message that there is no settings file, but it's ok if it's a new install.

File->new simulation.

And you get; Subscript out of range. Program exits without generating any files.

edit:If you first run 2.45.01 and run a new simulation once and exit it does ok on running 2.46.02Beta.
« Last Edit: January 09, 2014, 05:20:53 PM by Peter »
Oh my god, who the hell cares.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Subscript out of range when running fresh install with 2.46.02Beta
« Reply #2 on: January 09, 2014, 05:36:17 PM »
Confirmed and fixed, found another serious bug while investigating this one. Now it generates a file and still crashes. Expect an update by Friday.

Offline Botsareus

  • Society makes it all backwards - there is a good reason for that
  • Bot God
  • *****
  • Posts: 4483
    • View Profile
    • DJ Paul Kononov
Re: Subscript out of range when running fresh install with 2.46.02Beta
« Reply #3 on: January 09, 2014, 07:07:35 PM »
ok I got it. The two errors where related. I had to force the system to create an array.