Author Topic: Multibot teleport problems  (Read 2853 times)

Offline rayz

  • Bot Neophyte
  • *
  • Posts: 19
    • View Profile
Multibot teleport problems
« on: April 05, 2008, 09:17:28 PM »
I didn't know if there was a topic like this before, but here goes:

When I started my sim, I loaded "Massed Hunter with Poison and Shell and Slime" as a starting bot.  After a while, the bots started to coalese into a huge mass of bots all connected with hardened ties.  Then I turned on Internet Mode.  However, the teleporter refused to teleport my bots-- it treated them as one huge organism, attempted to save it as an organism file,  and failed miserably.  Now I just have this mass of bots in my sim that will not teleport.  Anyone have a tip to help me teleport my bots?

Thanks!

-rayz

Offline rayz

  • Bot Neophyte
  • *
  • Posts: 19
    • View Profile
Multibot teleport problems
« Reply #1 on: April 05, 2008, 09:26:09 PM »
Oh, and the size of the group of bots that are tied is ~1500 bots and rising.

Offline Numsgil

  • Administrator
  • Bot God
  • *****
  • Posts: 7728
    • View Profile
Multibot teleport problems
« Reply #2 on: April 05, 2008, 09:55:30 PM »
At some point Eric might decide to increase the 40 bot limit in .dbo files, but probably not soon.  In the mean time, well, I guess you'll have to figure out a way to get your bot in to a bite sized chunk   I'm pretty sure it's a 40 bot limit for .dbo files.
« Last Edit: April 05, 2008, 09:56:17 PM by Numsgil »

Offline EricL

  • Administrator
  • Bot God
  • *****
  • Posts: 2266
    • View Profile
Multibot teleport problems
« Reply #3 on: April 06, 2008, 01:02:50 PM »
The limit is 50 cells.   There is a 50 cell limit on teleportation or any sort including from one side of the field to the other in terroidal fields.  I think this is appropriate.  What should have happened is that some of your mass of bots - all those attached to the bot that encounterred the teleporter and those attached to those, etc. up to the 50 limit - should have gotten teleportted.  Some of them did teleport.  I saw them in my sim.   But you seem to imply there was an error of some sort.  What exactly occurred and could you please post a sim if you think something other than what I describe occurred?  Thanks.
« Last Edit: April 06, 2008, 01:03:46 PM by EricL »
Many beers....

Offline rayz

  • Bot Neophyte
  • *
  • Posts: 19
    • View Profile
Multibot teleport problems
« Reply #4 on: April 06, 2008, 04:45:10 PM »
Quote from: EricL
The limit is 50 cells.   There is a 50 cell limit on teleportation or any sort including from one side of the field to the other in terroidal fields.  I think this is appropriate.  What should have happened is that some of your mass of bots - all those attached to the bot that encounterred the teleporter and those attached to those, etc. up to the 50 limit - should have gotten teleportted.  Some of them did teleport.  I saw them in my sim.   But you seem to imply there was an error of some sort.  What exactly occurred and could you please post a sim if you think something other than what I describe occurred?  Thanks.

Apparantly the teleporter failed to break them up once.  It hasn't happened since.

Thanks!

-rayz