Author Topic: Working on 2.42.0  (Read 5090 times)

Offline EricL

  • Administrator
  • Bot God
  • *****
  • Posts: 2266
    • View Profile
Working on 2.42.0
« Reply #30 on: April 01, 2006, 12:42:30 PM »
The reset button is that button that says, um, "Reset" right above the initial position window on the Species tab.  It should reset the position box to be the entire field and let you find it. I think the problem is that the defaut size and Z-order on the dialog got messed up when VB crashed on me.  When you come back to it after setting the position, the size is probably still correct, you just can't see it because of the Z-order - its underneath what shoudl be the background...

Are you saying you get the Custom color selection box coming up when you click on a newly added species?  I do not see that.  The default color shoudl be Green and you should only get the custom color selection duialog if you select 'Custom' in the color dropdown.

-E

Edit:  I'm in the code .  The inital postion thing is move involved than just Z-order.  Will post more tonight...
« Last Edit: April 01, 2006, 01:28:02 PM by EricL »
Many beers....

Offline Testlund

  • Bot God
  • *****
  • Posts: 1574
    • View Profile
    • Games And Electronica
Working on 2.42.0
« Reply #31 on: April 01, 2006, 01:28:05 PM »
The custom color selection box only comes up if custom colors has been selected for that species before, just as in previous version. The boxes on the other hand... I can't select any postition where I want the species to appear. The only workaround is to click on the reset button, then click once in the box without moving it, then the species will appear spread out all over the field. But it's not possible to chose any other place or size where you want the species to appear. When it comes to the rest of the GUI... If you make settings on all the tabs, start a sim, save the sim, make new settings, start a new sim, then load the old sim, the old sim will only load some settings back. I found the following settings doesn't get saved:

General tab:
Waste treshold, Graphing update interval.

Physics and costs tab, Advanced costs:
All values have been reset to 0, except for the shell cost that displayed this value: 1,401298E-45. Clicking ok and then clicking on the Advanced costs button again will change the shell cost to 1.

Mutations tab:
Current multiplier doesn't get saved.

Restart and league tab:
Restart sim when all robots are dead doesn't work at all.

Recording tab:
Settings here doesn't get saved, and you can't have different values in the fields here.

There might be more settings that doesn't get saved, but these are the onces I've tested.
"God is an ever receding pocket of scientific ignorence." - Neil DeGrasse Tyson

"God is a kid with an ant farm" - Constantine

Offline Griz

  • Bot Overlord
  • ****
  • Posts: 608
    • View Profile
    • http://community.webshots.com/user/objack2
Working on 2.42.0
« Reply #32 on: April 01, 2006, 03:09:50 PM »
Quote
Are you saying you get the Custom color selection box coming up when you click on a newly added species? I do not see that. The default color shoudl be Green and you should only get the custom color selection duialog if you select 'Custom' in the color dropdown.
the very first time I click on the Veggie species in a new sim, it does. after that no.
just that one. surprised me as well. ;)
and yes, the reset does return to the default ... same size/aspect ratio as the field.
however, if you don't do this anytime before you click 'new' ...
the placement windows end up in those bizarre positions ...
my veggies all in a 0x0 field up in the upper lift corner ...
and other species smashed up against a wall or the top/bottom.
so, if you ever want to modify settings ...
you have to come back to species and place them where you want again.
and even then it doesn't always work.
I don't have control over their placement windows anymore ...
sometimes they're close ... other times ... they go wherever.
不知
~griz~
[/color]
   "The selection of Random Numbers is too important to be left to Chance"
The Mooj  a friend to all humanity
[/color]

Offline EricL

  • Administrator
  • Bot God
  • *****
  • Posts: 2266
    • View Profile
Working on 2.42.0
« Reply #33 on: April 01, 2006, 10:48:32 PM »
Okay, I've found and fixed all the issues Testlund mentions above with the exeception of the last two.

The inital position box thing was my fault, I broke it with a different fix that impacted the fractional starting positions of saved species.  It's solid now.  

The round trip issues through saves sims and settings files were a number of different things.  I fixed a couple of big things in 2.42.0 that I thought were to blame for all the issues, but didn't do sufficient testing and hadn't caught these.

In the graph update interval and waste threshold cases, the code was just never written to save those settings to sim or settings files (I just added the graph interval code in 2.42.0 and hadn't handled saves to sim files yet I assume the waste threshold was pretty new also).  The code to handle them for both sim and settings files has now been added.

In the costs case, an off-by-one error in two different loops was to blame, one in the sim save routine and another in the load routine.   These caused positional problems reading/saving sim files which meant that after a certain point in the file, what was read back in was essentailly random and the costs array near the end of the file took the brunt of the damage.  The entire array of all sim costs was messed up by this and was essentially random when read from any saved sim file.  It all works now.

The mutations slider thing was a case of aggressive initialization.  It was getting set to 1 in the sim initialize start routine no matter what got saved or loaded from the sim/settings files.

I'll work on the rest tonight or tomorrow and drop a 2.42.1 tomorrow.

-E
« Last Edit: April 01, 2006, 10:50:13 PM by EricL »
Many beers....

Offline Numsgil

  • Administrator
  • Bot God
  • *****
  • Posts: 7719
    • View Profile
Working on 2.42.0
« Reply #34 on: April 01, 2006, 11:20:25 PM »
Nice work.  Large projects like this are always 10% more bug fixing after you think you've finished, everytime you finish.  Very annoying.